The game doesn’t run in my browser, it’s asking me to install a plugin.

The game requires you to have a Flash Plugin installed. This plugin allows you to play awesome Miniclip games in your browser. You can get the latest plugin here:

http://get.adobe.com/flashplayer/

Have more questions? Submit a request
Powered by Zendesk