\

8 Ball Pool Crashing on iOS5

Although it is stated on the App Store that the minimum version required is iOS5, it is advised that only users with iOS6 or above download the game since it may have issues running on any versions prior do iOS6.

As 8 Ball Pool has been optimised to run more smoothly on higher iOS versions, it often happens that lowers versions of the software are unable to run the app.

If you are forced to install the latest version, please bear in mind this happens due to iOS Settings which you can change on your iTunes and App Store settings on your device. 

Any further information you may need regarding this subject, we advise you to contact Apple Support as it is beyond our reach.

We sincerely apologize for this inconvenience and appreciate your patience.

Have more questions? Submit a request
Powered by Zendesk